Problems signing into Superhuman
Incident Report for Superhuman
Resolved
Gmail has fixed the underlying issue and logging into Superhuman should be working now for all users. If you see any further issues, or have any questions, don't hesitate to reach out at hello@superhuman.com or twitter.com/superhuman.
Posted Aug 19, 2019 - 13:24 PDT
Update
Gmail's team has identified the problem and logging in is now working for most people.
Posted Aug 19, 2019 - 12:59 PDT
Investigating
We are experiencing some issues with Gmail right now, which may affect logging into Superhuman. We'll be sharing updates here and on twitter.com/superhuman as we learn more.
Posted Aug 19, 2019 - 11:29 PDT
This incident affected: Superhuman.