Sending delayed
Incident Report for Superhuman
Resolved
We've confirmed that all emails sent during the outage have successfully sent.
Posted Nov 07, 2018 - 23:41 UTC
Monitoring
A fix has been deployed. Emails will send successfully the next time Superhuman retries (usually 1-10 minutes). We will continue monitoring to ensure that all emails go out.
Posted Nov 07, 2018 - 23:09 UTC
Investigating
We investigating an issue that is causing emails to send slowly. All emails are safely stored on your device, and will automatically send when the issue is resolved.
Posted Nov 07, 2018 - 22:39 UTC
This incident affected: Email sending.