Emails are slow to send
Incident Report for Superhuman
Resolved
The incident has been resolved. Thanks for your patience!
Posted Jul 10, 2019 - 13:57 UTC
Investigating
Emails take a longer time than usual to send. We're investigating the issue. No data has been lost.
Posted Jul 10, 2019 - 12:18 UTC
This incident affected: Email sending.