Microsoft Outlook service disruption

Incident Report for Superhuman

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 05:25 PDT

Update

We are continuing to investigate this issue.
Posted Mar 31, 2025 - 05:24 PDT

Investigating

Outlook is currently experiencing a service disruption that may cause delays in email processing. The impact is limited to a small subset of users.
Posted Mar 27, 2025 - 09:47 PDT
This incident affected: Superhuman.