Load Balancer outage
Incident Report for Superhuman
Resolved
The issue seems to be resolved. We'll be working with our load balancer provider to avoid incidents like this in the future.
Posted Jul 17, 2018 - 19:58 UTC
Investigating
We're investigating an issue where our load balancers are incorrectly reporting Superhuman as offline.

Superhuman will continue to work, and emails will be sent when connectivity is resolved.
Posted Jul 17, 2018 - 19:25 UTC
This incident affected: Superhuman.