Small percentage of sends are failing due to Microsoft API errors
Incident Report for Superhuman
Resolved
This incident has been resolved.

The Microsoft team has deployed a fix last week and we haven't seen any new occurrences since Thursday afternoon.
Posted Dec 11, 2023 - 11:43 PST
Monitoring
We're not seeing any new send failures and some previously failing sends have been retried successfully.

We continue monitoring the situation to confirm that the problem has resolved itself.
Posted Dec 02, 2023 - 21:02 PST
Update
We do not have an update on a fix, but we continue to monitor the situation.

A handful of sends containing large attachments for Microsoft accounts continue to be unsuccessful.
We do not have a way to circumvent at this time.

We continue troubleshooting with Microsoft.
Posted Nov 30, 2023 - 17:14 PST
Investigating
We are seeing a small number of sends fail due to errors with the Microsoft API. Most users are not affected.

This only affects a small portion of emails with attachments over 3MB sent with Microsoft accounts.

If one of your emails fails to send you will see it at the top of your inbox with a red dot. Our current recommendation is to find an alternative way to send the attachment, e.g. Microsoft OneDrive or Dropbox.

We are in communication with Microsoft about this, and hope to have more information to share soon.
Posted Nov 30, 2023 - 11:09 PST
This incident affected: Email sending.