Network connectivity problems
Incident Report for Superhuman
Resolved
This incident has been resolved.
Posted Jul 17, 2020 - 21:51 UTC
Update
Our provider has resolve the underlying outage and everything should be back to normal.
Posted Jul 17, 2020 - 21:51 UTC
Update
It looks like our DNS provider is currently down.

We will continue to monitor the situation, and investigate possible short-term mitigations.
Posted Jul 17, 2020 - 21:35 UTC
Update
We are continuing to investigate this issue.
Posted Jul 17, 2020 - 21:34 UTC
Investigating
We are seeing connectivity issues connecting to Superhuman, and are investigating.
Posted Jul 17, 2020 - 21:28 UTC
This incident affected: Superhuman and Email sending.