Split Inbox modification failures

Incident Report for Superhuman

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 09:55 PDT

Identified

There appears to be an issue with creating or making changes to split inboxes. We have identified the problem and are working on a solution
Posted Jul 08, 2025 - 09:38 PDT
This incident affected: Superhuman.