Unstable Send Behavior from Android Devices

Incident Report for Superhuman

Resolved

This incident has been resolved. If you haven't updated to the latest version of Superhuman for Android, please do so by visiting the Google Play Store: https://play.google.com/store/apps/details?id=com.superhuman.mail
Posted Apr 04, 2025 - 09:04 PDT

Monitoring

We have released a new version of the app (version 1.12.12, build 6411) to the Google Play Store that includes a fix for the issue. You can check your current version at the bottom of your settings screen. We're keeping a close eye on things and expect everything to be fully resolved soon.
Posted Apr 03, 2025 - 15:49 PDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 03, 2025 - 15:46 PDT

Identified

We identified the issue and are pushing out a fix soon. This unstable send behavior effects Android users when they forward a thread with an attachment. We will continue to update our progress here as more information becomes available.
Posted Apr 03, 2025 - 10:58 PDT

Investigating

We are currently investigating an issue where emails fail to send from Android devices. This appears to be isolated to Android platforms, and all other platforms are functioning normally. Our team is actively working to identify the root cause and implement a fix. We will provide updates as soon as more information becomes available.
Posted Apr 03, 2025 - 07:04 PDT
This incident affected: Superhuman and Email sending.