Our services appear to be fully recovered. However, per Microsoft’s update, the issue is not yet considered resolved, and we will continue to monitor the situation closely.
Posted Jan 22, 2026 - 19:42 PST
Monitoring
Outlook services are showing signs of recovery, although Microsoft has not yet shared an official update.
Posted Jan 22, 2026 - 17:19 PST
Update
We are continuing to work on a fix for this issue.
Posted Jan 22, 2026 - 15:46 PST
Identified
The issue has been identified
Posted Jan 22, 2026 - 15:45 PST
Investigating
There appears to be an ongoing outage with Outlook services. At the moment, we are seeing degraded performance for sending emails.
Posted Jan 22, 2026 - 15:32 PST
This incident affected: Superhuman and Email sending.