Emails sending slowly
Incident Report for Superhuman
Resolved
We've fixed the slow-down and ensured that all delayed emails have been sent! 😊
Posted Oct 21, 2019 - 19:10 UTC
Investigating
We've noticed some instances of emails sending slowly. We're investigating this as our top priority now and will share updates here and at twitter.com/superhuman as we learn more.
Posted Oct 21, 2019 - 18:51 UTC
This incident affected: Email sending.