Inaccessible from some locations
Incident Report for Superhuman
Resolved
This incident has been resolved.
Posted Feb 08, 2019 - 16:22 UTC
Update
This turned out to be a mistake on our end, which is now resolved. Access should be restored everywhere over the next few minutes
Posted Feb 08, 2019 - 05:45 UTC
Investigating
We are currently investigating an issue where Superhuman is inaccessible from some locales, we're working with our infrastructure provider to debug.
Posted Feb 08, 2019 - 05:19 UTC
This incident affected: Superhuman.