Microsoft Outlook service disruption
Incident Report for Superhuman
Resolved
Microsoft has confirmed the issue is resolved after an extended period of monitoring. All systems are back to normal.
Posted Feb 07, 2023 - 09:10 PST
Update
We are continuing to monitor for any further issues.
Posted Feb 07, 2023 - 09:09 PST
Update
Microsoft is reporting the majority of impact has been repaired, with service availability at 99.9%. We'll continue to monitor until Outlook is back to 100%.
Posted Feb 07, 2023 - 07:49 PST
Monitoring
Microsoft has implemented a fix and we are starting to see a gradual recovery.
Posted Feb 07, 2023 - 04:43 PST
Update
Microsoft has identified the problem and are working on a resolution, but have not yet provided a timeline to resolve the issue. Email sending and receiving is still degraded for some Outlook accounts.
Posted Feb 06, 2023 - 23:12 PST
Identified
Outlook is experiencing a service disruption and email sending might be delayed.
Posted Feb 06, 2023 - 21:40 PST
This incident affected: Email sending.