Delayed sending and signing in
Incident Report for Superhuman
Resolved
We’ve now fixed the underlying issue, and notified all users who’s emails did not send.
Posted Dec 12, 2018 - 20:47 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 12, 2018 - 04:46 UTC
Update
Message sending and signing in should now be working normally. We're still investigating the underlying root causes internally.
Posted Dec 12, 2018 - 02:23 UTC
Investigating
We're investigating an issue that causes sending and signing in to Superhuman to slow, and sometimes fail. Your emails are safely stored on your device, and will send when the issue is resolved.
Posted Dec 11, 2018 - 23:20 UTC
This incident affected: Superhuman and Email sending.