Elevated Memory Usage

Incident Report for Superhuman

Resolved

This incident has been resolved.
Posted Aug 29, 2025 - 03:39 PDT

Update

Issues are resolved. We're continuing to monitor.
Posted Aug 29, 2025 - 03:10 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 29, 2025 - 02:04 PDT

Investigating

We're experiencing an elevated level of memory usage preventing emails from being sent and logging in. We are currently looking into the issue.
Posted Aug 29, 2025 - 01:24 PDT
This incident affected: Superhuman and Email sending.