Google Account Login Outage
Incident Report for Superhuman
Resolved
It appears these login issues are fixed! We'll stay on the lookout just in case anything else crops up, but you should be able to return to your regularly scheduled emailing now. :-)
Posted Apr 17, 2019 - 23:41 UTC
Monitoring
Google login seems to be getting better, so you may be able to log in now if you couldn't earlier. We're still keeping an eye on things and will share any more progress we see.
Posted Apr 17, 2019 - 23:10 UTC
Investigating
We’re seeing problems with signing into Superhuman. The cause is an outage of Google’s login system that also prevents signing into Gmail. We’re in touch with Google and will share updates here as we have them.

If you like, you can also follow along here on Google's status page:
https://status.cloud.google.com/incident/cloud-iam/19001
Posted Apr 17, 2019 - 22:35 UTC
This incident affected: Superhuman.