Delayed email sending
Incident Report for Superhuman
Resolved
Google have resolved the relevant incident on their side, and emails are now sending successfully from Superhuman again!

If any of your emails failed to send during the last few hours, they will show up in your inbox in Superhuman and can be retried or skipped as appropriate.
Posted Jun 03, 2019 - 00:07 UTC
Update
We're seeing an increase in delayed sends as the issues with Google Cloud and Gmail continue, affecting about 15% of emails sent. We'll continue monitoring the situation and let you know as things change.

https://www.google.com/appsstatus
https://status.cloud.google.com/
Posted Jun 02, 2019 - 23:11 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2019 - 20:53 UTC
Investigating
We're monitoring an issue that causes delays to send emails in some instances. This is due to networking issues with our hosting provider, Google Cloud. Google Cloud is aware of the issue and is actively working on fixing this issue.

Your emails are safely stored on your device, and will send when the issue is resolved
Posted Jun 02, 2019 - 20:48 UTC
This incident affected: Email sending.