Sending delayed
Incident Report for Superhuman
Resolved
We have resolved the issue, and all emails have sent.
Posted Nov 16, 2018 - 23:21 UTC
Investigating
We're investigating an issue causing emails to send slowly.
Posted Nov 16, 2018 - 22:38 UTC
This incident affected: Email sending.