Connection issues and delayed sends
Incident Report for Superhuman
Resolved
The database is back up and running in a stable configuration, so we're considering this incident resolved for now.

We will be making further changes around midnight PST this evening to re-enable high availability on the instance. This will require approximately 10 minutes of downtime.
Posted Dec 07, 2019 - 23:19 UTC
Update
We are about to revert the workaround, this will cause under 2 minutes of further downtime; but will restore Superhuman to a stable state.

Your client may appear offline for a few minutes, but will reconnect and re-send any outstanding emails when the service returns to normal.
Posted Dec 07, 2019 - 22:25 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 07, 2019 - 20:34 UTC
Investigating
We have implemented a workaround, which we hope will restore Superhuman access temporarily; and we continue to stay in touch with Google's team as they work on fixing the root cause https://status.cloud.google.com/incident/compute/19012.

Queued up emails should begin to send when your client next reconnects
Posted Dec 07, 2019 - 19:17 UTC
This incident affected: Superhuman and Email sending.